INSTALL.quagga.txt 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. --------------------------------------------------------------------------
  2. Building and Installing Quagga from releases or snapshots:
  3. The 'INSTALL' file contains generic instructions on how to use 'configure'
  4. scripts.
  5. Quagga requires a C compiler (and associated header files and
  6. libraries) supporting the C99 standard.
  7. Quagga requires a reasonable make. It is considered a bug if quagga
  8. does not compile with the system make on recent FreeBSD, NetBSD or
  9. OpenBSD, and a very serious bug if it does not compile with GNU make.
  10. Quagga expects a POSIX.2 compliant system, more or less. Clean
  11. workarounds for POSIX non-compliance are welcome.
  12. It is considered a bug if Quagga fails to build and run on any of the
  13. following systems (where .x indicates the most recent release), or
  14. such systems "-current" versions. (Note that considering it a bug is
  15. not a guarantee of support, merely "we agree that it is broken".)
  16. Dragonfly ?
  17. FreeBSD 4.x [In 2007, this is getting tenous.]
  18. FreeBSD 5.x
  19. FreeBSD 6.x
  20. FreeBSD-current
  21. Linux [kernel/distribution information needed]
  22. NetBSD 2.x [Note texinfo 4.6 in base system]
  23. NetBSD 3.x
  24. NetBSD 4.x
  25. NetBSD-current
  26. OpenBSD ? [info needed on what should work]
  27. Solaris 9
  28. Solaris 10
  29. For further Quagga specific information on 'configure' and build-time
  30. configuration of the software, please read the Quagga info
  31. documentation, (doc/quagga.info). To read the info page included with
  32. the Quagga sources without first installing Quagga:
  33. cd doc
  34. # one of the following, depending on your info viewer preferences
  35. info quagga.info
  36. pinfo -r quagga.info
  37. emacs -eval '(info "quagga.info")'
  38. The Quagga website (http://www.quagga.net) currently has the info
  39. files available in various formats.
  40. --------------------------------------------------------------------------
  41. Building Quagga from CVS checkouts:
  42. In order to build from CVS, you will need recent versions of several GNU
  43. tools, particularly autoconf, automake, libtool, GNU awk and texinfo. Note
  44. that the CVS snapshots on the Quagga website should not require these tools;
  45. everything is already setup ready to run 'configure'. If you have trouble
  46. building from CVS checkout it is recommended that you try a CVS snapshot
  47. instead.
  48. We declare that the following versions should work for building from
  49. CVS checkouts. Earlier versions may work, but failure to do so is not
  50. a bug. Required versions can be moved earlier if no problems, or
  51. later after a judgement that a system without a higher version is
  52. deficient is made.
  53. automake: 1.9.6 (released 2005-07-10)
  54. autoconf: 2.59 (2.60 on 2006-06-26 is too recent to require)
  55. libtool: 1.5.22 (released 2005-12-18)
  56. texinfo: 4.7 (released 2004-04-10; 4.8 is not yet common)
  57. GNU AWK: 3.1.5 (released 2005-08-12)
  58. Becuase some systems provide texinfo 4.6 (4.7 is new), quagga.info is
  59. checked in so that texinfo will generally not be invoked. When
  60. texinfo 4.7 is widespread, quagga.info will be removed from CVS and
  61. texinfo will become required again. (4.7 has figure support, needed
  62. for the route server docs, which is why 4.6 doesn't work.)
  63. In order to create PostScript or PDF versions of the Texinfo documentation,
  64. you will need the convert utility, from the ImageMagick toolset installed,
  65. and epstopdf from the TeTeX suite.
  66. To create the required autotools files (Makefile.in, configure, etc.),
  67. run "./bootstrap.sh". After this you may run configure as for a
  68. snapshot or release.
  69. Please refer to "Building and Installing Quagga" above for further
  70. instructions.
  71. --------------------------------------------------------------------------
  72. Notes on required versions:
  73. The general goal is to use a modern baseline of tools, while not
  74. imposing pain on those tracking stable distributions. The notes below
  75. explain what versions are present in various environments.
  76. NetBSD 1.6 and 2 provide texinfo 4.6. This is now considered old.
  77. NetBSD 3 and 4 provide texinfo 4.7.
  78. Fedora Core ? provides autoconf 2.59.
  79. OpenBSD 3.6 provides texinfo 4.2.
  80. OpenBSD [3.6] ports provides automake 1.4-p6 autoconf 2.5.9 libtool 1.5.8
  81. --------------------------------------------------------------------------