Browse Source

bgpd: Fix unhandled enum warning for AFI_ETHER

* bgp_open.c: (bgp_afi_safi_valid_indices) We have AFI_ETHER defined, but
  don't handle it at this point.
Paul Jakma 4 years ago
parent
commit
7fa7acb492
1 changed files with 2 additions and 0 deletions
  1. 2 0
      bgpd/bgp_open.c

+ 2 - 0
bgpd/bgp_open.c

@@ -143,6 +143,8 @@ bgp_afi_safi_valid_indices (afi_t afi, safi_t *safi)
 	case SAFI_ENCAP:
 	  return 1;
 	}
+    case AFI_ETHER:
+    default:
       break;
     }